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11.1. Computer-aided design of electronic devices 
 

Computer-aided design CAD is established in many industrial areas. CAD design 
means that we use tools of information technologies IT in the design process. CAD 
design consists of hardware, specific software and external devices, and interfaces. The 
core of CAD design is program package that uses graphics for display, different 
datasockets and drivers for peripheral devices. CAD design does not change design 
process but significantly facilitates and speeds it up. These tools are very efficient 
especially at designing devices that need to be ecologically efficient. Many tools already 
contain tools that help analyze and evaluate if the design is ecological. Some tools also 
contain datasockets with elements and materials that are part of the design. The 
essence of CAD design is summed in the following points: 

• Precise graphical presentation of the product. It is also easier to analyze, 
modify or upgrade it.  

• Enables complex design in very short time.  

• Enables simulation of different events, such as electrical, chemical, thermal 
and mechanical.  

• With simulation tools, it is easier to provide optimal approach to design 
and the product itself. 

The first CAD tools have been developed for space and automotive industry. 
Latter, CAD tools have expanded to other engineer areas, such as electronic and textile 
industry, packaging, etc. 

CAD tools have originally been intended for automatization of design processes 
and system modeling. Modern CAD tools support most activities in the design phase. 
They contain information on product characteristics and used materials. These tools also 
serve as a common platform for data exchange between different design groups and 
teams. They can contain information on production and are often called CAD/CAM tools 
(computer aided manufacturing). Image 1 presents the process of ordinary and 
CAM/CAD design. CAD tool shortens design time, which consequently means that the 
product will be on the market sooner and product development will be cheaper. CAD 
tools also save design process, which enables faster and easier upgrade of the initial 
version. Image 2 presents average time spent on product design and its use. The shorter 
design time is, the longer the usefulness of the device on the market. This condition is 
only valid if the design is done correctly.  
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IMAGE 1: EXAMPLE OF CLASSIC AND CAD/CAM DESIGN. 

 

 

IMAGE 2: AVERAGE TIME OF DESIGN AND PRODUCT USE. 

 

In the following chapter, we will present CAD tools that are intended for designing 
electronic devices. 
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11.2.  Designing printed circuit boards  
 

Designing printed circuit boards PCB is the key task of each development process. 
Well designed circuit and printed matter itself influence the quality, as well as device 
reliability. With design process, we determine all elements and the size of the circuit. 
When choosing components and printed matter size, we can meet many ecological 
guidelines. Usually, we use components that are smaller, less energy consuming and the 
design circuits that require less space.  Today we know many advanced technologies 
that enable multi-layer printed matter. These enable smaller circuit surface and 
consequently lower material consumption. On the other hand, we need to know that 
production technology is much more expensive and uses more energy, which is less eco-
friendly. When designing printed matter, we need to find a compromise between 
chosen elements and printed matter size that it will have a lower ecological impact in 
the production phase. Apart from these aspects, we need to consider certain guidelines 
and regulation on printed matter design with the intention of achieving high reliability 
and quality of printed matter and the final device. 

The standards for printed matter design are monitored by IPC association. They 
manage printed matter production standardization and material use. The main 
document that covers design of printed circuit boards is document ICP-2221 - Generic 
Standard on Printed circuit board Design. 

The standard steps in printed matter design are: 

• Project specification.  

• Electrical scheme design.  

• Circuit design.  

• Prototyping. 

• Testing. 

• Production. 

Currently, there are many tools on the market that enable designing of printed 
circuits. Here are some of the most commonly used:  

• AutoTRAX (Scheme, PCB design with built-in Spice simulator) 

• Advanced Design System (Intended for RF electronics  - mobile phones, 
WiFi network, satellite communication, radars, VF circuit - VF simulators)  

• Eagle (Scheme, PCB design, available free version for smaller projects, 
academic environment, 3D view, etc.).  

• Altium designer (Used to be Protel, schemes, PCB, support for FPGA – Field 
Programmable gate array, with the programming option, translation of 
program code, 3D view)  

• OrCAD tools (Scheme, PCB)  

• CADSTAR (Scheme, diagrams, PCB, available free version with basic 
functions CADSTAR Express)  

• KICAD (open-code environment, scheme, PCB and 3D view) 
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11.2.1 Designing electronic schemes 

 

When designing electronic schemes, it is important that the scheme is organized, 
relations are logical, and there is as little crossing as possible. A good scheme is also 
designed in a way that it is very similar to the final printed matter. For example, if we 
want to place a capacitor near a certain electronic component, then we also draw it near 
the symbol or component in the scheme. We stick to the unwritten rule that all inputs 
are on the left and all outputs on the right side of the scheme. If necessary, we also use 
comments and notes. In complex circuits, we define scheme areas for better visibility. 
All areas together make the complete device scheme. The areas are only virtual scheme 
sections that round up the parts of the circuits. For example, we draw the power supply 
part separately or on a certain area of the scheme. The controlling part is also designed 
on its own area, etc. Image 3 presents the classical scheme for printed circuit board 
design. 

 

IMAGE 3: SCHEME FOR DESIGNING A PRINTED CIRCUIT BOARD. 

 

11.2.2 Designing printed matter  

Equally important is making the scheme for the next step in printed matter 
production. Designing printed matter consists of element arrangement and connections 
between them. With production of printed matter, we determine the final appearance 
of printed matter. In the production, it is very important that we use element libraries. 
In these, we can find characteristics and dimension of the element, as well as names of 
connected clamps. In printed matter production we need to consider the following rules: 

• Printed matter choice (material, width). 
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• A number of printed matter layers. 

• Layer arrangement. 

• Circuit arrangement on printed matter. 

• Consideration of parasitic impacts.  

• The component layout on printed matter.  
 

 

IMAGE 4: PRINTED MATTER - PCB. 

 

In printed matter production, we often encounter different metric systems. 
Electronic components usually have dimensions and arrangement of connection legs 
presented in inch units. In Europe, metric units are used more often. Inch unit is more 
often used for dimensions of connections, copper connectors, and pads. Metric units 
are used for determining hole dimension, printed matter size and circuit housing 
dimensions.  

 
Copper lines 

Copper line thickness is chosen depending on electrical requirements and space 
on printed matter. Thicker lines give faster responses and better results. Wider and 
thicker lines have lower resistance and shorter length, their production is easier and 
cheaper, they are easier to be repaired and examined. When choosing printed matter 
manufacturer, we need to know what are some of the closest lines and the smallest 
spacings that the manufacturer can still provide. 

For example, offer 10/8 means that the lines cans can be at least 10 mil wide and 
the distance between them can be at least 8 mil. The typical offers are 10/10 or 8/8. 
Generally, printed matter with 12/12 can be produced by almost every manufacturer. 
IPC standard recommends the lowest limit up to 4/4. Smaller distances can mean the 
costs of producing printed matter are significantly higher. An example of good practice 
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of using a wider line and its narrowing at places where it is necessary is presented in 
image 5. This way, we can retain lower total impedance.  

 

IMAGE 5: EXAMPLE OF NARROWING LINE . 

Wire width and length is determined by electrical current and electrical signal 
frequency. For higher currents, it is recommended that we use as thick lines as possible. 
More narrow lines have higher resistance, which causes losses and unwanted conductor 
heating. Table 1 below presents recommended line width depending on the current at 
a temperature increase of 10˚C.   

 

 Preffered Line Width (mil) 1mil=0.0254mm 
Current [A] 1oz  Width (µm) 2oz Width (µm) 

1 350 175 
2 1050 525 
3 1750 875 
4 2800 1400 
5 3850 1925 
6 5250 2625 
7 6300 3150 
8 7700 3850 
9 9100 4550 

10 10500 5250 

TABLE 1: COPPER LINE WIDTH IN PRINTED MATTER BY CURRENT. 

Copper wire resistance is calculated with the formula:  

𝑅 =
𝜌𝐶𝑢𝑙

𝑆
,   𝜌𝐶𝑢 = 1.724 × 10−6Ω𝑐𝑚, 

Where 𝑅  is resistance,  𝑙  length, 𝑆  cross-section and 𝜌𝐶𝑢  specific copper 
resistivity. Line length is conditioned by anticipated signal frequency. Example of good 
practice gives an estimation on line length depending on signal frequency: 
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𝐿 =
1

20
𝜆 =

1𝑐

20𝜐
 , 

where 𝐿   is permissible line length, 𝜆  is wavelength, 𝜐  is wave frequency, 𝑐  is 
speed of the light. At high frequency signals the, condition cannot be fulfilled, so it is 
necessary to consider signal propagation time on the given line, which causes time 
delay. In parallel conductors, it is important that they are shorter and equal in length. 
Most program packages correct lengths of critical conductors. At high frequency lines, 
we also avoid RF connectors, which cause disturbances and signal loss. 

Vertical interconnect access 

VIAs are metalized copper lines with different layers. They are very similar to 
connecting pads that we must not confuse them with. The connection pad is part of the 
component socket, and VIA only bridges connections between different printed matter 
layers. Image 6 presents VIA in multilayer printed matter.  

 

IMAGE 6: VIA IN MULTILAYER PRINTED MATTER. 

Polygons 

Polygons are used for filling larger areas with pure copper or copper texture, seen 
in image 7. Polygons are interconnected by connection pads and VIAs. Usually, they are 
used for substituting grounding and power supply surfaces. We install them at the end 
after all other copper lines are already plotted. 

 

a)                                                                                            b) 

IMAGE 7:PRINTED MATTER POLYGON; A) TOP LAYER, B) COPPER TEXTURE. 



  

 Ecodesign of electronic devices  
UNIT 11: Computer-aided design of electronic devices 

Page 9 of 31 

 

When plotting polygon and lines, we need to consider the empty space between 
lines or polygon. Too small distances are not preferable because they can cause hairline 
short circuits that can occur in the production phase. We also need to consider the lower 
limit for producing printed matter. It depends on the manufacturer and production 
technology. The common rule is 15 mil for wire components and 8 to 10 mil as the lower 
limit for elements that are montaged on the surface. For circuits that work at network 
voltage 230 V/110 V, we need to consider safety standards that are valid for a certain 
geographic area. The basic rule is that between phase and zero current has to be at least 
3.2.mm of distance. The smallest distance between high-voltage parts and parts with 
which user can come in contact with is 8mm. A simple guideline is that the distances 
should be bigger rather than smaller when it is inside the granted dimensions! 

By dimensions, we also need to consider galvanic isolation. These distances are 
defined by IPC standard. Distances differ by whether they are inside or outside of printed 
matter and the area where the electronic component will be used (humid environment, 
altitude, etc.). We often protect printed matter with lacquer coating that increases 
galvanic corrosion resistance and protects the circuit from external effects. Table 2 
presents standard distances and layers for different components of a printed circuit by 
voltage. Galvanic isolation is determined by breakdown voltage. Breakdown strength is 
a material characteristic that is given by the following formula: 

𝐸𝑝 =
𝑈𝑝

𝑑
    [

𝑉

𝑚
], 

where 𝐸𝑝  is electrical breakthrough strength, 𝑈𝑝 is electric voltage and 𝑑  is an 

isolant dimension. Different isolants have different electric breakthrough strengths, 
presented in table 3.  

 

Voltage Internal layers External conductors 
uncoated 

External conductors 
coated 

[V] [mm] [mm] [mm] 

15 0.05 0.1 0.05 
20 0.05 0.1 0.05 
50 0.1 0.6 0.13 

100 0.1 0.6 0.13 
150 0.2 0.6 0.4 
170 0.2 1.25 0.4 
250 0.2 1.25 0.4 
300 0.2 1.25 0.4 
500 0.25 2.5 0.8 

1000 1.5 5 2.33 
4000 9 20 11.48 
5000 11.5 25 11.53 

TABLE 2: PRESCRIBED DISTANCES FOR GALVANIC ISOLATION OF PRINTED MATTER LINES. 
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Isolant (20C̊) 
𝐸𝑝  [

𝑉

𝑚
] × 106 

Air 3 
Paper 10 

Pubber 10 
Transformer oil 15 

Porcelain 20 
Polyvinyl Chloride-PVC 50 

Polystyrol 80 

TABLE 3: ELECTRIC BREAKTHROUGH STRENGTH OF SOME MATERIALS. 

 

Basic rules for connecting printed matter components  

The connection of components means installation of copper lines on printed 
matter between component connectors. Electric connections between two or more 
connection pads are called electric signal network. We strive for shorter electric signal 
network because longer lines cause more serious parasitic effects. The lines should 
break at 45° angle, or we can use rounded lines. Copper lines are connected at the 
middle of connection pads, for which we use working network or function “snap to 
object”, which depends on program package. The connection between two points can 
consist of only one line. For higher currents is necessary to use larger VIAs, which 
decrease impedance and increase reliability. Between connection pads on distance 
100mil, we decrease line width. Power supply and grounding lines should be wider for 
higher current loads. Power supply and grounding lines have to be set as closely together 
as possible, which can be efficiently blocked by capacitance elements. There should be 
no copper “islands” without connections. These islands have to be grounded or deleted. 
Image 8 presents different ways of connecting elements. 

 

                  a)                                                                         b)                                                    c) 

IMAGE 8: PRINTED MATTER CONNECTIONS: A) APPROPRIATE, B) APPROPRIATE, C) NOT APPROPRIATE. 

 

Choosing printed matter 

When choosing materials for the printed matter, we have different possibilities 
that differ in several characteristics, such as: fire safety, temperature stability, moisture 
absorption. These characteristics are defined by international association NEMA - 
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National Electrical Manufacturers Association. Table 4 presents an overview of materials 
for production of printed matter. 

Material  Comment 

FR-1 Bakelite: at room temperature poor moisture resistance. 
FR-2 Bakelite: suitable for single-layered PCBs, good moisture resistance. 
FR-3 Epoxy resins: a balanced material with good mechanical and 

electrical properties. 
FR-4 Glass fibers: excellent mechanical and electrical properties. 
FR-5 Glass fibers: high strength at high temperatures, self-extinguishing. 
G10 Woven glass and epoxy: high insulation resistance, maximum 

mechanical strength, high moisture resistance. 
G11 Woven glass and epoxy: resistant to bending at high temperatures, 

extreme solvent resistance. 
CEM-1 Cotton paper and epoxy. 
CEM-2 Cotton paper and epoxy. 
CEM-3 Non-woven and epoxy. 
CEM-4 Woven glass and epoxy. 
CEM-5 Woven glass and polyester. 
PTFE Pure - expensive, low dielectric loss, for high-frequency applications, 

very low moisture absorption (0.01%), mechanically soft. Difficult to 
laminate, rarely used in multilayer applications. 

RF-35 Fiberglass-reinforced ceramics-filled PTFE. Relatively less expensive, 
good mechanical properties, good high-frequency properties. 

Alumina Ceramic: Hard, brittle, very expensive, very high performance, good 
thermal conductivity. 

Polyimide A high-temperature polymer: Expensive, high-performance, higher 
water absorption (0.4%). Can be used for cryogenic temperatures to 
over 260 °C. 

TABLE 4: TYPES OF MATERIALS FOR PRINTED CIRCUITS. 

Label FR stands for flame retardant material. The thickness of the copper coating 
on printed matter is by standards 0.5oz(18 µm), 1oz(35 µm) or 2oz(70 µm). There are also 
other standards that are less often used (12 µm) and (105 µm). The printed matters with 
aluminum or metal core have a copper coating of even 70µm to 400µm. The most often 
used material in industrial environments is FR-4. This material is the optimal choice 
regarding price and causality.   

When designing printed matter, we also choose a number of layers. The high 
number of layers generally increases production costs but also enables production of 
smaller and more resistant printed matters.  

• One-sided printed board: It is suitable for simple low-frequency circuits, 
as seen in image 9. The circuit can be produced with many bridges. Such 
circuits have worse resistance to electromagnetic disturbances. 
Designing of complex circuits on one layer PCB requires much more effort 
and innovativeness. Usually, they are used for pilot devices and early 
component testing.  

• Two-sided printed board: Often are made of material FR-4, as seen in 
image 10. The circuit is easier to be connected with. If possible, the 
bottom surface is intended for grounding, and other connections are left 
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on the top surface. Advantages of grounding surface are increased 
mechanical stability of printed matter and lowered impedance of all 
grounding connections (reduces noise). It adds distributed capacitance to 
each connection on the top layer, which helps prevent electromagnetic 
disturbances. It acts as a shield from electromagnetic noise, the source of 
which can be printed matter environment.  

• Multi-sided printed matter: There can be 4, 6, 8, 10 or up to 38 layers 
used. These are more suitable for sensitive high-frequency devices. The 
usual thickness of 2-sided printed matter is 1.5mm, which is too much. At 
a smaller distance between the upper and bottom layer, we achieve 
better distributed capacitance. It is also easier to connect the power 
supply and grounding connections (power supply and grounding layers). 
Connecting is easily done through VIAs. Other signal lines have a lot of 
space on all other layers, which significantly simplifies connecting. Higher 
capacitance distribution between the power supply and grounding layers 
which decreases high-frequency noise. It also better blocks EMI/RFI 
disturbances. Production of multi-layer printed matters is significantly 
more expensive in comparison to those circuits with fewer layers.  

 

IMAGE 9: ONE-SIDED PRINTED MATTER. 

 

IMAGE 10: TWO-SIDED PRINTED MATTER. 
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IMAGE 11: MULTI-LAYER PRINTED MATTER. 

 

11.3. Examples of using Altium Designer program 
 

Program Altium-Designer is a professional environment for designing printed 
circuits in all phases, which are: 

• Designing of flowcharts and block diagrams.  

• Designing of printed circuit boards-PCB. 

• Designing software for FPGA (Field Programmable Gate Array). 

• System solutions for FPGA and debugging (when working with suitable 
development boards, such as Altium NanoBoard). 

• Designing built-in systems. 

• Simulation tools for digital and analog circuits. 

• Signal quality analyses. 

• Management of PCB production processes. 
 

Altium includes editors and program interfaces for all steps of electronic device 
design. Writing and editing of program code together with translating is done inside 
Altium Designer environment. In our case, we will pay more attention to drawing and 
designing of the printed circuit board for an electronic device. Content is designed in a 
way that offers an overview of different PCB design phases. The first design phase 
includes an outline of the electrical scheme. The second phase includes translation of 
the scheme into printed circuit. In this phase, we determine printed matter dimensions, 
element arrangement, and connections. In the third phase, we will show how to present 
the printed matter in a 3D environment and the possibilities for using it in other CAD 
programs. For this case, we will take a look at current generator circuit, seen in image 
12. 
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IMAGE 12: CURRENT GENERATOR SCHEME. 

 

11.3.1 Creating a new project 

For each new printed matter, it is recommended to create a new project because 
in a project we have saved all document and settings that are related to the design 
process. Project file xxx.PrjPCB is ASCII file in which are written all output documents 
and settings, such as printing settings and CAM. Documents that are not related to the 
project are called free documents. We also add links to electrical schemes, PCB, FPGA, 
built-in VHDL (Verilog hardware description language) and libraries. When the project is 
completed, all designs are synchronized inside the documents in the project. The project 
is created with the following set of commands: 

• Choose File → New → Project → PCB Project, image 13. 

 

IMAGE 13: CREATING A NEW PROJECT. 

• We can see window Projects, where project PCB_Projects.PrjPcb is listed 
without attached documents. 
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• Rename the project, in our case to Current_ generator.PrjPcb, so it can be 
saved on disc location of our choice with the next command. File → Save 
Project As → Current_generator.PrjPcb. 

 

Then create a new file for designing electrical scheme 'schematic'. Create new 
scheme.  

• Choose File → New → Schematic. We can see file Sheet1.SchDoc that is 
added to the previously created project automatically, seen in image 14.  

• Rename scheme to Current_generator.SchDoc. Save the scheme, File →  
Save As → Current_generator.SchDoc. 
 

 

IMAGE 14: CREATE CIRCUIT SCHEME. 

 

When an empty scheme is opened, we can see a completely changed view with 

different keys, menus, etc. Now we are in the editor for electrical schemes. If we want 

to add already outlined scheme of another project to the created scheme, then choose 

Add Existing to Project. 

Before we start designing electrical scheme, we need to set the following: 

• Setting format for worksheet: Design → Document, Option – choose format A4. 

• The worksheet can be enlarged with a combination of CTRL key + scroll wheel; 

view can also be fit to full screen with command View → Fit Document [shortcut: 

V, D]. 

• There are many settings that can be accessed from the menu Tools → Schematic 

Preferences [shortcut: T, P], where the settings will influence all schemes in the 

working project.  

• Click on the scheme and select Default Primitives and enable option Permanent, 

which offers basic preset values when we select an electrical element from the 

library and not the settings that we set in the previous step.  
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Scheme design begins with choosing an element, seen in image 12. In the library of 

elements, we search for all elements, starting with operational amplifier MCP602. 

Altium has very strong support for libraries of electrical components, such as schemes, 

sockets and 3D models. These libraries are not yet installed, but we can download them 

free of charge from Altium website (https://designcontent.live.altium.com/.) if we have 

a valid license. We can also download freely accessible libraries from 2004 and extend 

the folder where we have already installed basic library by Altium.  

To search for correct amplifier MCP602, click Libraries and then Search (or click 

Tools → Find Components) and then opens dialogue window Libraries Search.  

We need to be careful that we have all components selected and that we search 

in mode Libraries on path where we have to have written the correct path for installed 

libraries. For the higher possibility of results when searching do not enter all signs, but 

only the main ones because different manufacturers have different prefixes and 

suffixes. To do this, enter the search string between two asterisks (in our case: *602*). 

If we choose a component from the list that is not yet installed, then we get the option 

to confirm that we can install it immediately which can later be executed. For MCP602 

we need to previously install library by manufacturer Microchip (Microchip Linear 

Devices.IntLib), and then MCP602 is available, so we can select it as seen in image 15.  

   

 

To insert, double-click the component which enables moving of the element into 

the working area with the cursor. Before we move it to a certain place, we can edit labels 

and properties which can be enabled by pressing the tab key. Then in the field 

Designator enter a component label that we will see in the scheme (in our case: U1A). 

At the model check, if the component has a correct socket (in our case: SMD SOIC – 8 

connectors). When we have set everything needed, we can start with inserting 

components into the scheme. The component can be set to the wanted position by 

IMAGE 15: CHOOSING MCP602 FROM THE LIBRARY. 

https://designcontent.live.altium.com/
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clicking or pressing ENTER. Then move the cursor and see that with the next click we can 

insert another OPA from which the label U1A is automatically increased to U1B, and 

other preset properties remain unchanged. Altium environment enables multiple 

insertions of components of the same type which is revoked by key ESC.  

In the next step, we will insert 7 resistors. For inserting, we will use a basic library 

that is installed in Altium environment under name Miscellaneous Devices.IntLib. Type 

*Res* in the search engine and then select resistor with socket SMD type 2010 that is 

labeled as Res3. Select value 25k that is the most common value and can be later 

changed at certain resistors. Reset Designator to the lowest value R1 and start with 

entering values, as seen in the previous example. Then rename two resistors to Rref and 

Rb by clicking on each one separately and change the name in field Designator, as seen 

in image 16.  

 

IMAGE 16: CHOOSING RESISTOR FROM THE LIBRARY. 

  Do the same with elements voltage stabilizer LM336 (2.5V, housing TO92) from 

library ST-Electronics 'Power Mgt Voltage Reference.IntLib', capacitors (search string 

*Cap*) and connector terminals (search string *Header*) that can be found in library 

Miscellaneous Devices.IntLib, seen in image 17. 
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IMAGE 17: CHOOSING LM336, CAPACITOR AND CONNECTION TERMINALS. 

 

Next, arrange the components correctly in the scheme while considering the rule 
inputs on the left and outputs on the right site. We need to be careful that there is 
enough space between the components for connections because if we connect 
electrical connection over connection pins, then the program will automatically 
connect it with the crossed connector, image 18.  

 

IMAGE 18: ELEMENT ARRANGEMENT. 

 

To the existing components, we also need to add voltage potentials, such as zero-

grounding  and power supply . For test purposes, we will insert GND and power 
supply Vdd (insert them at several places to retain better scheme visibility). When 
connecting components, we need to consider the following rules: 

• We need to have a good overview of the complete scheme. 
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• Draw connections with the tool  Place Wire [shortcut: P,W]. Pay 
attention to interconnections to prevent short circuits. 

• If we want to move components after we have connected them, we need 
to delete current connections, move the components and then reconnect 
them again. We can also use combination CTRL + moves with the mouse, 
which enables moving of components together with previously made 
connections. 

The finished wiring diagram can be seen in image 19.  

 

IMAGE 19: CURRENT GENERATOR SCHEME. 

We also need to add to the scheme names of individual connections (nets and 
net labels) that can be later used in printed matter. Connection names are not essential 
for circuit functioning but serve as notes or references when reviewing finalized circuit 
or for later repairs. Component connectors are connected with nets. Some connections 
with higher importance and potentials in the electrical scheme can be named with the 
name of our choice. By using symbols for GND and Vdd we have automatically set two 
names. When choosing Menu → Place → Net label [shortcut: P, N] we get the option to 
set name to any connection. By pressing TAB, we can change settings, such as color, 
arrangement and font type for net label before we define to which connection we will 
set the new name, as seen in image 20.  
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IMAGE 20: WINDOW FOR SETTING CONNECTION NAME, FONT TYPE, COLOR, SIZE, ETC. 

 

In our circuit, we will use connection name for reference voltage Vref shown in 

image 21.  

 

 

IMAGE 21: DEFINED NAME FOR CONNECTION VREF . 

 

With this, we have finished drawing and designing electrical scheme, which is the 

basis for moving onto designing the printed circuit board. Before we start translating the 

scheme into printed matter, it is recommended to configure project settings. This 

includes settings for detecting errors, connection matrix, class generator, settings for 

the comparator, generating warning messages, settings for printing, etc. Altium uses all 

these settings when translating a project. When the project is translated, the complete 

design and electrical rules that were set are checked. After all errors are solved, the 

scheme is again translated and uploaded into the target project with for example PCB 

document. Project comparator enables searching for differences between the source 

and target files that we see and can be confirmed or rejected (synchronized) from both 

directions. All settings are available under menu Project → Project options. 
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11.3.2 Determining printed matter  

After wiring diagram is finished and the settings are correct, we can start 
translating wiring scheme into printed matter. In the transaction phase, all electronic 
scheme design rules are checked with possible error tracking and the repair option. To 
translate given project Current_generator.PrjPcb we need to choose Project → Compile 
PCB project. When translation is finished, the translator message is visible in the 
message window. To access this window, we need to go to View → Workspace Panels 
→ System → Messages. Translated documents will be recorded in window View → 
Workspace Panels → Design Compiler → Navigator, where we can monitor document 
structure, list of components and connection types (when clicking the connection we 
can also see it with marked lines in the scheme). In case of errors and unsuccessful 
translation, these events are recorded in window Error Messages. If the translation is 
successful, we can move to a new document in which we can design printed matter with 
the given electrical scheme. First, we create empty PCB. The easiest way is by using 
interface PCB Board Wizard with which we can choose between standardized industrial 
formats or own dimensions. Later these settings can be changed. PCB Board Wizard can 
be found under menu Files, which needs to be enabled in order to be visible, as seen in 
image 22. If file choosing is not enabled, then we have a row of shortcuts to certain 
function at the right bottom of the scheme, and under tab System, we can tick Files.  

 

IMAGE 22: CHOOSING SHORTCUT TO FILES. 

Document preparation follows these steps: 

1. First click PCB Board Wizard and in the second windows select metric units 

Metric, image 23. 
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IMAGE 23: WIZARD FOR CREATING PCB.  

2. In the third window choose between PCB formats. We can choose Custom and 

then enter dimensions W=40 mm, H=30 mm. For designation of PCB edge, 

select line type Mechanical Layer1. 

3. In the next two windows choose a number of layers and type of VIAs that go 

through the whole PCB thickness.  

4. Then select which component type we will mostly install on PCB (SMD, PDIP, 

etc., depending on the socket) and on how many sides. Most components are 

surface-mount and are installed only on one side. 

5. In the following window select recommended settings for connections and 

VIAs: 

a) The smallest connection thickness = 0,25 mm 

b) The smallest VIA width = 1 mm 

c) The smallest VIA diameter = 0,6 mm 

d) The smallest distance between connections = 0,25 mm 

Image 24 presents two wizard windows for printed matter settings. 
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IMAGE 24: STEPS IN PRINTED MATTER SETTINGS FROM 2 TO 5. 

 

After successful creation of printed matter, we see a window with selected 
dimensions. In order not to have white page background, remove it in settings by clicking 
Design → Board options → Display sheet. PCB view can be adjusted with command 
View → Fit board or shortcut [V,F], seen in image 25. 

 

 

a)                                                                                            b) 

IMAGE 25: ADJUSTED VIEW OF PRINTED MATTER A) WITH BACKGROUND, B) WITHOUT BACKGROUND. 

 

PCB dimensions can be later changed. The easiest way is to draw desired frame 
shape which can be used for determining PCB borders. This can be done by clicking all 
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lines that define PCB edges with mouse and then select the function from menu Design 
→ Board Shape → Define from selected objects, to trim PCB to the desired shape, 
image 26.  

 

IMAGE 26: CUSTOM PCB SHAPE. 

 

11.3.3 Project translation - Compiling 

First go into electrical scheme environment and translate Design → Update PCB. 
Click Validate Changes, where error probability is checked. If everything is correct, there 
will be confirmation checkmarks under status. If the changes are not correct, we need 
to return back, check error messages and solve the errors. When the error check is 
successful, click Execute Changes, which transfers components and connections to PCB 
in the project, image 27.  

 

IMAGE 27: CHECKING SCHEME DURING COMPILING. 

 

Transfer of components to PCB printed matter, image 28. 



  

 Ecodesign of electronic devices  
UNIT 11: Computer-aided design of electronic devices 

Page 25 of 31 

 

IMAGE 28: SHAPE OF ELEMENTS FOR PRINTED MATTER. 

From image 28 we can see that arrangement of elements to printed matter is up 
to the designer. In this case, it is sensible to consider guidelines and instructions of good 
printed matter design. In the next step follows the arrangement of components to 
printed matter. Components are arranged by clicking on the component and moving it 
to the correct position (click with the left button and press it while moving the 
component). Stay within PCB limits. With spacebar we can rotate the component while 
transferring it. Text that is connected to the components can also be moved the same 
way as components. 

 

IMAGE 29: ARRANGED COMPONENTS ON PRINTED MATTER. 

 

Altium environment has  function support for the easier component arrangement. 
Several components can be aligned horizontally, vertically, by different edges or center 
line. They can also be aligned with uniform spacing. These functions can be accessed if 
we select component group, where we use key SHIFT or round around the components 
we want to select. Then click with right mouse button and choose Align → Align 
[shortcut: A, A] and mark wanted functions on X and Y axle. Also, when we select one or 
multiple components, we can move them with mouse or use key combination: CTRL + 
SHIFT and arrow keys. This means a combination of an arrow key and CTRL causes  
smaller move (snap grid x 1) in wanted direction than when we press both keys CTRL + 
SHIFT, which causes the components to be moved for larger distance (snap grid x 10).  

The connection of arranged elements can be made manually or automatically. In 
manual connection, we have a better overview of connections and the work takes longer 
to be done. Manual connecting is most often used in larger printed matters. Automatical 
connecting is generally more useful in less complex circuits. 
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Manual connecting of PCB printed matter  

Manual PCB connecting means establishment of connections and VIAs on printed 
matter in order to connect all components as presented by the electric scheme. In 
manual mode, we usually design more complex printed matters, where many design 
aspects are important, such as EMI influence, RF circuit design, combined analog and 
digital circuits, combined power electronics, and digital/analog circuits, etc. Many times 
the designer has to decide and take compromises between certain design parts. 

In our case, we will do manual connecting, although the circuit is simple. We will 
try to draw signal connection on the top layer, for lower layer we will use GND mass, 
which we will access through VIAs and in certain cases with connection pads (connectors 
P1 and P2 and reference U3). The connections consist of sequential segments. At each 
change starts a new connection segment. Generally, Altium enables arrangement of 
connections in vertical, horizontal arrangement and  at 45° angle (at advanced settings 
we can also use curves) to get a final professional result.  

We will use standard settings. First, we will choose view Top layer. Use shortcut L 
to get to the menu View configuration, where we remove the checkmark at Bottom 
layer and confirm the change, seen in image 30.  

 

 

IMAGE 30: CHOOSING PRINTED MATTER TOP LAYER . 

 

Connecting start with . We can only connect those components or connectors that 
are interconnected electrically in the scheme, which is in PCB environment presented 
by thin straight lines between connection pads. By pressing key CTRL and clicking certain 
connection pad, we can easily check which pads are interconnected. When we create a 
connection between two connectors, we can finish it with automatic function Auto-
complete. This can be done by clicking the first connector and then the second one and 
during that press CTRL and arrow key >. The connection will be created in the shortest 
way between both connectors. This function is successful if the path is fairly simple 
without major obstacles between both points. The second way is by using key ENTER 
when connections are finished gradually, with which we decrease the number of 
segments in one connection. Altium enables other ways of manual connecting where 
we can press SHIFT + R during moving and select between different methods: 

• Push – In this mode, the connection will try to break through to the other point 
by moving already established connections and VIAs within the rules. 

• Walkaround – Path to the second point is trying to find by drawing the 
connection around obstacles without moving existing connections and VIAs.  
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• Hug & Push – This way is a combination of previous ones.  
• Ignore – This method allows establishment of connections anywhere without 

breaking the rules.  

We need to be also aware of the components that we set on the top surface, 
where are also signal connections and those that have connection pads routed though 
PCB to the other side. Such components are soldered below, so we need to connect 
them with signal connections on the top side with VIAs. VIAs can be found with key Place 

via . Because we will use the bottom layer for mass, VIAs will be installed at 
connectors P1, P2, and the reference. 

Apart from components and VIAs, it is also good to predict how PCB will be 
attached to the housing because we usually need screw holes. Those can be created by 

selecting Place Pad . Do not connect it to any electrical connection. Mark option 
Plated, so there will be no error messages later on when checking PCB.  

 

Now we need to fill the bottom side of printed matter with the mass GND. This can be 

achieved by clicking button  Place Polygon Plane from the toolbox, set its 
characteristics and then define polygon limits by drawing them in PCB, as seen in image 
32 and 33.  

 

IMAGE 32: DETERMINING POLYGON FOR MASS ON THE BOTTOM PRINTED MATTER SIDE. 

IMAGE 31: CONNECTED PRINTED MATTER. 
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IMAGE 33: PRINTED MATTER WIT ADDED MASS GND ON THE BOTTOM SIDE. 

Automatic routing  

Simpler and less complex PCBs can be connected with an automated regime 
where all rules are strictly met. In our case, we want a signal line on the bottom side 
and the bottom side of PCB to be reserved for GND polygon. For this, we need to adjust 
the settings, so connections will be only on the top side. This can be done in rules. 
Design → Rules and under Routing Layers we enable only Top Layer, image 34. Then 
select from the menu Auto Route → All and click Route All. 

 

 

IMAGE 34: CHOOSING UPPER LAYER FOR AUTOMATIC CONNECTION BETWEEN COMPONENTS. 

 

IMAGE 35: RESULT OF AUTOMATIC CONNECTING. 
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At first glance, the result is similar, but the detail that we manually entered makes 
a difference. There are quite a few mistakes that we can overlook in printed matter. It 
is also not considered that the components that are soldered on the bottom side the 
electrical contact only on the bottom side, so they need to be connected with 
connections with VIAs on the top side. VIAs are welcome at GND connections because 
we can make them shorter. If we connect automatically, it is sensible to use connection 
groups Net classes. These can be set through user interface Design → Classes. Here we 
can add groups by going to the tab Net classes and by right click choose Add class. We 
can see a window where all available electrical connections are written in the column 
Non-members and on the right is space where we can add wanted/marked connection 
with a click on arrow. 

 

  

 

 

IMAGE 36: ADDING CONNECTION GROUPS. 

3D view 

3D view enables that we can see PCB in space from all perspectives. We can switch 

between views 1, 2 and 3. Number 3 is a shortcut for the 3D view, seen in image 37.  

 

IMAGE 37: 3D VIEW OF PRINTED MATTER. 

 

In the 3D view we can use the following shortcuts:  

• Zooming in: CTRL + mouse scroll  

• Moving up/down: mouse wheel, moving left/right: SHIFT + mouse scroll 
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• Rotation: SHIFT + right key on mouse and drag in the wanted direction that can 

be selected on sphere with arrows.  

Altium enables import of 3D objects from different CAD tools in *.step* format. It 

is also possible to export in formats, such as: step, dwg/dxf. Exported objects can be 

used in other CAD programs that support mentioned formats.  

 

Final documentation  

Final or export documentation can be split into 5 groups: 

1. Parts list 

a. Plans for automatic robotic component arrangement. 

b. Plans for placing components on both PCB sides.. 

2. Output documentation 

a. Component plans including copper connections. 

b. 3D views of PCB. 

c. Schematic display of electronic circuits. 

3. Documentation for printed matter production 

a. Composite Drill Drawings – plans for holes, their position and size, all in 
one plan. 

b. Drill Drawing/Guides – plans for holes and instruction for making, 

their position and size in separate drawings.  

c. Final Artwork Prints – in one plan there is a lot of different output 
information. 

d. Gerber Files - Gerber files, made for each PCB layer separately. 

e. NC Drill Files -  for numerical controlling (CNC) of drilling machines. 

f. ODB++ - Creating datasockets for manufacturer in ODB++ format, 
socketd on C++. 

g. Power-Plane Prints – plans for internal and separate layers.  

h. Solder/Paste Mask Prints – plans for protected layers. 

i. Test Point Report – report on testing points.  

4. Netlist Outputs – list of connections  

a. The lists present logic connecting between components (in 

different text formats, CSV (comma separated values) 

5. Output reports 

a. Bill of Materials – list of materials that we need for the making of the 
electrical circuit. 

b. Component Cross Reference Report – list of components based on the 
electrical scheme. 

c. Report Project Hierarchy – list of all documents. 

d. Report Single Pin Nets – list of connections that have only one 
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connector.  
Documentation for production needs  

In the last phase, we need to deliver all needed documents to the PCB manufacturer 
that are needed before making of PCB. For this, we need to send Gerber and NC drill 
files and material list.  
 
Saving of Gerber files – Each Gerber file corresponds to one physical printed matter 
layer with all possible line profiles (Component overlay, signal layers, solder masking 
layers, etc.). Before sending and saving of Gerber files, it is recommended to consult 
the manufacturer to be unified with their requirements.  

 


